Telephone Ordering Outage

Incident Report for AMSOIL Web Properties

Resolved

AMSOIL telephone services are operational. Thank you for your patience while we worked to resolve the issue.
Posted 3 months ago. Jan 23, 2025 - 07:20 CST

Update

AMSOIL telephone services continue to be down due to a global carrier outage. Product orders may still be placed online and you may contact AMSOIL with questions or comments through the Contact Us page, https://www.amsoil.com/contact/.
Posted 3 months ago. Jan 22, 2025 - 14:54 CST

Identified

We are experiencing a telephone outage. Customers are unable to reach Customer Service or reach any call queue through the main AMSOIL phone numbers. We are investigating the cause and working to get it back online as soon as possible. We will send additional updates as we learn more.
Posted 3 months ago. Jan 22, 2025 - 14:16 CST
This incident affected: Telephone Ordering.