Degraded Site Performance

Incident Report for AMSOIL Web Properties

Resolved

We have successfully resolved the issue causing degraded performance on AMSOIL.com and AMSOIL.ca. We apologize for any inconvenience this may have caused.
Sincerely,

AMSOIL INC.
Posted Mar 06, 2024 - 17:30 CST

Update

We are continuing to investigate the cause of degraded performance on AMSOIL.com and AMSOIL.ca. We appreciate your patience as we work to fix this issue.
Posted Mar 06, 2024 - 16:05 CST

Investigating

A technical issue is causing degraded performance on AMSOIL.com and AMSOIL.ca. We are investigating the cause and will send an update when the issue is resolved. We appreciate your patience as we work to fix this issue.
Sincerely,

AMSOIL INC.
Posted Mar 06, 2024 - 13:49 CST
This incident affected: AMSOIL Dealer Business Tools (Dealer Zone (Rallyware), Dealer Zone Reports, EZ Order Forms, Dealer Application & Renewal, Retailer Application, Commercial Application, DBS), AMSOIL Storefronts (AMSOIL.com Storefront, AMSOIL.ca (English) Storefront, AMSOIL.ca (French) Storefront), and AMSOIL Web Applications (AMSOIL Vehicle Lookup Guides, MyAMSOILGarage, AMSOIL Locator, On-Site Search).