PayPal Orders Temporarily Unavailable

Incident Report for AMSOIL Web Properties

Resolved

We’re pleased to inform you that the technical issue affecting PayPal orders on AMSOIL.com and AMSOIL.ca has been resolved. You can now place orders using PayPal as normal.

Thank you for your patience and understanding while we worked to fix the issue.

Sincerely,
The AMSOIL Team
Posted Jun 02, 2025 - 14:03 CDT

Identified

We are currently experiencing a technical issue on AMSOIL.com and AMSOIL.ca that is preventing orders placed using PayPal from being processed. Our team is actively investigating the issue and working to resolve it as quickly as possible. We will provide an update as soon as the problem is resolved.

Thank you for your patience and understanding.

Sincerely,
The AMSOIL Inc.
Posted Jun 02, 2025 - 13:31 CDT
This incident affected: AMSOIL Storefronts (AMSOIL.com Storefront, AMSOIL.ca (English) Storefront, AMSOIL.ca (French) Storefront).