Telephone Ordering Outage
Incident Report for AMSOIL Web Properties
Resolved
Telephone ordering is back online and functioning normally. We apologize for any inconvenience this may have caused. Thank you for your patience while we worked to resolve this issue.

Sincerely,

AMSOIL INC.
Posted Mar 19, 2024 - 17:40 CDT
Identified
We are experiencing a telephone outage. Customers are unable to reach Customer Service or reach any call queue through the main AMSOIL phone numbers. We are investigating the cause and working to get it back online as soon as possible. We will send additional updates as we learn more.

Sincerely,

AMSOIL INC.
Posted Mar 19, 2024 - 16:29 CDT
This incident affected: Telephone Ordering.