We have successfully resolved the issue causing degraded performance at on AMSOIL.com, AMSOIL.ca and the Dealer Zone. We apologize for any inconvenience this may have caused. Sincerely,
AMSOIL INC.
Posted Jan 28, 2025 - 08:41 CST
Identified
A technical issue is causing degraded performance on AMSOIL.com, AMSOIL.ca and the Dealer Zone. Account login and access to the Dealer Zone are impacted. We are investigating the cause and will send an update when the issue is resolved. We appreciate your patience as we work to fix this issue.
Posted Jan 28, 2025 - 08:33 CST
This incident affected: AMSOIL Dealer Business Tools (Dealer Zone (Rallyware), Dealer Zone Reports), AMSOIL Storefronts (AMSOIL.com Storefront, AMSOIL.ca (English) Storefront, AMSOIL.ca (French) Storefront), AMSOIL Web Applications (AMSOIL Vehicle Lookup Guides, MyAMSOILGarage, AMSOIL Locator, On-Site Search), and Telephone Ordering.